How to Upgrade from osTicket 1.7RC6 to 1.7ST

Now that osTicket 1.7ST is finally out people are of course going to want to upgrade. If you are running v1.6ST or are running any of the DPR or RC of 1.7 I highly recommend that you upgrade immediately. If you are running version 1.6ST please read: How to upgrade OSTicket from 1.6ST to 1.7RC4. If you were running rc6 please read on.

The upgrade from RC6 to ST is incredibly simple because there were no database structure changes between the two versions. Most of the file changes from RC6 to ST are actually in mail handling. Here's the list of what to do. Normally I would tell you to always back up your database (and create a backup of your root web directory), and while it is best practice to do so I personally do not find it particularly necessary this time. [note: if you have modified your 1.7RC6 installation you should still back it up even if its just as a reminder to you how you modified it so as to re-create those modifications again.]

  • Download the 1.7.0 package
  • Extract the zip, and copy EVERYTHING into your current osticket folder.
  • Crack the can open, because your done.

Okay your not really done. For security reasons you should really go into your osTicket folder and delete setup. If you don't and you go to your admin panel you will receive the annoying message of

"Please take a minute to delete setup/install directory (../setup/) for security reasons.

But wait! That's too easy you say! Aren't I supposed to go to osTicketInstall.ext/setup/upgrade.php? Well you can if you really want to, but you will see the red warning message saying:

Nothing to do! System already upgraded to 1.7.0 with no pending patches to apply.

Remember how at the beginning I mentioned that there are no database changes between 1.7RC6 and 1.7ST? There really are not any. Enjoy.